CarAudioForum.com

Go Back   CarAudioForum.com > Discussion Forums > Car Audio: Advanced

Reply
Old 06-03-2004, 06:09 PM   #1
sneekie1

Registered User
 
Join Date: Mar 2004
Posts: 20
sneekie1 is on a distinguished road



hifonics amp in protection mode

the other day i was driving and the amp just popped into protected mode. i wasn't even thumping my sub. i have a hifonics z1000d amplifier. i tried disconnecting all the wires and connected it in again but it was still in protected. does anyone have any suggestions on how to fix the problem?
sneekie1 is offline   Reply With Quote

Sponsored Links
Help Syrian Refugees Survive. Donate Now!
Or text REFUGEES to 50555 to give $10 to USA for UNHCR
Old 06-03-2004, 06:57 PM   #2
Maki

Registered User
 
Join Date: Aug 2000
Location: Metro Manila, Philippines
Posts: 240
Maki is on a distinguished road



have you verified if your sub is fine? one probable cause is that ur vc is shorting, therefore presenting a short on the ouput of the amp... if after removing the sub, the amp is still in protec mode, its time to send it to hifonics or a local dealer to have it checked...
Maki is offline   Reply With Quote

Old 06-03-2004, 07:50 PM   #3
sneekie1

Registered User
 
Join Date: Mar 2004
Posts: 20
sneekie1 is on a distinguished road



am i able to send it into hifonics for them to check it?
sneekie1 is offline   Reply With Quote

Old 06-03-2004, 08:15 PM   #4
Dr dB

Registered User
 
Join Date: Jun 2004
Location: Manchester UK
Posts: 14
Dr dB is on a distinguished road



Simply dissconnect all speakers from the amp. Remove all inputs too. Power up the amp and if the protect led still comes on then the amp is at fault (assuming the supply voltage is in good health).
Dr dB is offline   Reply With Quote

Old 06-04-2004, 12:08 AM   #5
Maki

Registered User
 
Join Date: Aug 2000
Location: Metro Manila, Philippines
Posts: 240
Maki is on a distinguished road



yah, i think they'd accept it, but call or email their tech support for more info, even though if it costs more, you'd have warranty from hifonics on the work done on your amp...
Maki is offline   Reply With Quote

Old 06-06-2004, 01:16 PM   #6
sneekie1

Registered User
 
Join Date: Mar 2004
Posts: 20
sneekie1 is on a distinguished road



will a blown fuse on the power wire to the battery cause the amp to go into protection mode or will the amp not turn on at all?
sneekie1 is offline   Reply With Quote

Old 06-06-2004, 10:38 PM   #7
Maki

Registered User
 
Join Date: Aug 2000
Location: Metro Manila, Philippines
Posts: 240
Maki is on a distinguished road



first of all check why it blew...theres always a reason...

and it depends on the amp if it goes to protect mode or not, i have experiences with some older earthquake amps that go into protect mode even only when the rem and the ground wire is connected, on some amps,(an i think its normal) the amp doesn;t even try to turn on...=)
Maki is offline   Reply With Quote

Old 06-10-2004, 04:07 PM   #8
sneekie1

Registered User
 
Join Date: Mar 2004
Posts: 20
sneekie1 is on a distinguished road



i hooked up my amp to my friends car and it still went into protect mode. this probably means that my wiring is fine and that its the amp right? how do i check what caused the amp to go into protect mode? could it be the fuse on the amp went bad?
sneekie1 is offline   Reply With Quote

Old 06-11-2004, 02:56 AM   #9
thylantyr

Registered User
 
Join Date: Jan 2002
Location: [Yoda] Belong to us all your base are...
Posts: 12,539
thylantyr has a reputation beyond reputethylantyr has a reputation beyond reputethylantyr has a reputation beyond reputethylantyr has a reputation beyond reputethylantyr has a reputation beyond reputethylantyr has a reputation beyond reputethylantyr has a reputation beyond reputethylantyr has a reputation beyond reputethylantyr has a reputation beyond reputethylantyr has a reputation beyond reputethylantyr has a reputation beyond repute



A blown fuse means no power to the amplifier.

Sounds like the amp needs repair.
thylantyr is offline   Reply With Quote

Old 06-11-2004, 04:59 PM   #10
sneekie1

Registered User
 
Join Date: Mar 2004
Posts: 20
sneekie1 is on a distinguished road



how do i get the amp for repair? are there any places in southern cali that will help me repair my amp?
sneekie1 is offline   Reply With Quote

Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:36 PM.
Powered by vBulletin® - Copyright © 2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1996 - 2011 by CarAudioForum.com - all rights reserved.